Square Hardware Disruption
Incident Report for MoeGo
Resolved
The Square team has released a fix for the earlier disruption. Thank you for your patience with us as we work to resolve this issue.
Posted Jun 23, 2023 - 10:43 PDT
Identified
Square engineers have implemented a fix to the unexpected restarts that Square hardware was experiencing. We will continue to monitor the progress and report back with any updates. Thank you for your patience.
Posted Jun 21, 2023 - 11:58 PDT
Investigating
We are currently experiencing a disruption that is causing the Square hardware to unexpectedly restart. The Square Engineering team is actively working to identify and work on a fix. Thank you for your patience with us as we work to resolve this issue. See more details: https://www.issquareup.com
Posted Jun 20, 2023 - 11:27 PDT
This incident affected: Square payment.