Square Payments Disruption
Incident Report for MoeGo
Resolved
We’re no longer seeing elevated levels of payment declines and card processing activity has returned to normal. The Square team will continue to work on uncovering the underlying cause of the earlier disruption and putting in place safeguards to help prevent issues of this nature from recurring in the future.
We understand how important it is for all of our services to be running for your business, thank you for your patience with us as we monitored the situation.
Posted Feb 06, 2023 - 17:17 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 06, 2023 - 15:36 PST
Investigating
We have recently been made aware of this issue, Square is currently down. For your reference: https://www.issquareup.com
Until this is resolved, you will need to accept payment using another method, or set up MoeGo pay to accept card payment. We are sorry for this inconvenience caused by the Square outage.
Posted Feb 06, 2023 - 14:01 PST
This incident affected: Square payment.