MoeGo app can't be opened on Android(and how to fix it)
Incident Report for MoeGo
Resolved
This incident has been resolved.
Posted Dec 28, 2022 - 19:09 PST
Investigating
Due to an error that occurred during the system upgrade, the MoeGo app might not be open on your Android devices.
To fix this, please delete the app and then download it again. Then the issue should be resolved.
Our team will launch a permanent fix for this issue soon.
Posted Dec 23, 2022 - 08:18 PST
This incident affected: MoeGo Mobile App.