Square Payment Acceptance Degraded Performance
Incident Report for MoeGo
Resolved
This incident has been resolved.
Posted Jun 25, 2023 - 19:07 PDT
Update
Square is aware that this disruption may impact your business, and their team is working to roll out a fix as soon as possible. To clarify this is only affecting Mastercard transactions attempted with mobile wallets (e.g. Apple Pay/Google Pay) all other payment methods including physical Mastercards are completed successfully. For more information please check: https://www.issquareup.com/
Posted Jun 24, 2023 - 14:44 PDT
Identified
Square has identified the root cause affecting Mobile Wallet payments completed with Mastercard. They are currently working on implementing a fix. We will continue providing updates here as they occur. As mentioned earlier, we recommend attempting payments using a physical Mastercard or an alternate form of payment. For more information: https://www.issquareup.com/
Posted Jun 23, 2023 - 11:23 PDT
This incident affected: Square payment.