We have employed a temporary workaround for users with the customized domain email setting enabled. In order to keep email campaign running, we have temporarily disabled the customized domain email setting. For these users, their email campaigns will be sent from a default MoeGo email until we fully resolve the issue. For other users, email campaign is working without issue. We are currently working with our email service provider on a full resolution and will provide further updates soon.
Posted Aug 13, 2026 - 03:54 PDT
Monitoring
A interim solution has been implemented to resolve the issue. Email campaign delivery has been restored for most users. However, users with custom email domain may still experience issue with email campaign delivery. We are currently working with our email service provider on a full resolution. This will take some more time and we will share more updates.
Posted Aug 13, 2026 - 00:35 PDT
Investigating
We are currently investigating an issue preventing the delivery of email campaigns. Please note that other emails, such as automated notifications and reminders, remain completely unaffected. We will provide another update as soon as we have more information.