Degraded Performance: Square payment
Incident Report for MoeGo
Resolved
This issue has been fixed. Everything's great now!
Posted Jun 01, 2022 - 13:23 PDT
Identified
We are receiving confirmed reports of issues that are impacting Square payment due to an error that happened to Square's API. Square team has located the source of the impacted services and is working to implement a fix.
We’ll be back to update as soon as we can once we receive more information from Square team.
Posted Jun 01, 2022 - 12:03 PDT
This incident affected: Square payment.