Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 09, 2025 - 00:00 PDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 28, 2025 - 00:24 PDT
Scheduled
We have scheduled a database upgrade on May 9, 2025, at 3:00 AM EST. The maintenance is expected to last 10 minutes, during which our services will be temporarily unavailable for approximately 3 minutes.
Posted Apr 28, 2025 - 00:24 PDT
This scheduled maintenance affected: MoeGo Mobile App and MoeGo Web Version.